WordPress后台慢的问题解决了,看到推荐的应用上提示最好将PHP升级到7.4,想想腾讯云上安装的MediaWiki也是用的PHP7.4,咬咬牙决定升级一下。
这台阿里云服务器用的是OneinStack一键安装脚本,按照作者的意思,如果想要升级大版本要么就是直接卸载低版本后安装高版本,要么就安装多个版本同时运行。用
error-oniguruma.png

yum install oniguruma oniguruma-devel

安装完oniguruma继续升级PHP,又是漫长的等待,依然报错。这次换了个花样,见下图
error-CURLAUTH_GSSAPI.png
大体上能看出跟curl有关,用curl -V命令检查了一下现在的版本,7.53.1。
尝试升级(这个过程用去我两天时间,中间还回滚过一次快照才勉强解决,具体再开一篇文章单独讲),最新版本为7.73.0。
重新升级PHP,这次终于顺利安装完毕。

参考文章:
CentOS 7/8 安装 oniguruma 和 oniguruma-devel

最后修改:2020 年 12 月 05 日 10 : 35 AM
如果觉得我的文章对你有用,请随意赞赏